12 September, 2011

How to export a site, list, or document library-SharePoint Server 2010

Mandatory Requirements:
You must create a folder on the local computer or the network in which to store the export file.
How to export a site, list, or document library by using Central Administration:
  1. Verify that the user account that is performing this procedure is a member of the Farm Administrators group.
  2. In Central Administration, on the Home page, click Backup and Restore.
  3. On the Backup and Restore page, in the Granular Backup section, click Export a site or list.
  4. On the Site or List Export page, in the Site Collection section, select the site collection from the Site Collection list, and then select the site from the Site list.
  5. If you are exporting a site, skip this step, Select the list or document library from the List.
  6. In the File Location section, in the Filename box, type the UNC path of the shared folder and the file to which you want to export the list or document library. The file name must use the .cmp extension.
  7. If the file already exists and you want to use this file, select the Overwrite existing files check box. Otherwise, specify a different file name.
  8. If you want to export all the security and permissions settings with the list or library, in the Export Full Security section, select the Export full security check box.
  9. If you want to specify which version of the list or library to export, select one of the following versions from the Export versions list:
1)       All Versions
2)      Last Major
3)      Current Version
4)      Last Major and Last Minor
  1. When you have specified the settings that you want, click Start Export.
If you have any queries/questions regarding the mentioned information then please let me know…

Server error: http://go.microsoft.com/fwlink?LinkID=96177

Problem Description:
Where to check and how to cross checked:
·         Open the Event viewer application and check 4 these event ID’s:
5617, 100, 104
Error Message: Server error: http://go.microsoft.com/fwlink?LinkID=96177
Probable causes:
1.       Windows Update
2.      Service pack installation
Resolution:
1.       Create a new web application with a new test database
2.      Central Administration
3.      Application Management
4.      Content Databases
5.      Change the web application to the new one that you had created
6.      Detached the database
7.      Change the web application to the problem site and detached the database for that web application as well
8.     Command prompt and run the below mentioned command
Stsadm -o addcontentdb -url <type new url address> -databasename <type database name>

 If you have any queries/questions regarding the mentioned information then please let me now...
I would be more than HAPPY to HELP U as well as RESOLVES UR Issues :-) :-)

No results matching your search were found

Problem Description:
When you try to perform search on your SharePoint site on your SharePoint server then you are getting the below mentioned error message:

No results matching your search were found.
Check your spelling. Are the words in your query spelled correctly?
Try using synonyms. Maybe what you’re looking for uses slightly different words.
Make your search more general. Try more general terms in place of specific ones.
Try your search in a different scope. Different scopes can have different results.


What to check first: Make sure the Windows SharePoint help search is working

Resolution:
Create a registry in the following location:
1.      HKLM\System\CurrentControlSet\Control\Lsa
2.      Create a new DWORD key named “DisableLoopbackCheck” and modified the value  to 1
3.      Performed Full Crawl by using the stsadm command:
stsadm -o spsearch -action fullcrawlstart

That’s it-Your issue will be resolved and Search will start working without any problems.

If you have any queries/questions regarding the mentioned information then please let me know...
I would be more than HAPPY to HELP U as well as RESOLVES UR issues :-) :-)

Event ID 8214: “Object reference not set to an instance of an object”

Problem Description:
When you perform Check-Out documents from the Document Library where document check-out is required from the SharePoint site in your SharePoint farm, you are getting following error message
“Object reference not set to an instance of an object”
Impact: You are not able to open and edit any office documents
When you will not face the issue: You are not facing the issue on the document library where check-out is not required to edit the documents
Why the problem occurred: Issue started to occur when you installed WSS 3.0 SP2 on you SharePoint server
How you will cross checked: Event Viewer ApplicationàEvent ID 8214
Event Type:        Error
Event Source:    Windows SharePoint Services 3
Event Category:                Topology
Event ID:              8214
Date:                     5/12/2009
Time:                     3:21:14 PM
User:                     N/A
Description:
The description for Event ID ( 8214 ) in Source ( Windows SharePoint Services 3 ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: A request was made for a URL, http://novashare, which has not been configured in Alternate Access Mappings.  Some links may point to the Alternate Access URL for the default zone, http://spadmin.  Review the Alternate Access mappings for this Web application at http://spadmin/_admin/AlternateUrlCollections.aspx and consider adding http://spadmin as a Public Alternate Access URL if it will be used frequently.  Help on this error: http://go.microsoft.com/fwlink/?LinkId=114854.
Resolution:
1.       Central Administration site
2.      Operations
3.      Alternate Access Mappings
4.      Show AllàChange Alternate Access Mapping Collection
5.      Select the Web Application which belongs to the problem site
6.      There is a URL that is reflecting in “Default” zone
7.      Now specify the URL which is giving you problem in the “Intranet” zone
8.     IISRESET
That’s it- Your issue will be resolved and you should be able to check-out and edit the office documents