14 December, 2013

Error while executing web part

Nowadays pretty much busy in SP2013 assignments and didn’t get a time to publish any article but today I would like to share some useful information about data view webpart.

Before I start writing about the problem description and its resolution, please refer the following links that will give you some insight about data view webpart-

Problem description-
Recently I was working on user ticket in which we have restored one site collection from development environment to production one.  This site has been heavily customized using SharePoint designer. Restore was successful and but while opening the home page of the site, it throws an exception as follows

Error message-
Error while executing web part: Microsoft.SharePoint.WebPartPages.WebPartPageUserException: Personalization has been disabled for this zone.

Let me tell you that this issue was very inconsistent as sometimes it works and sometimes throws the above mentioned error message. It’s been happening with a limited set of users so we checked their permissions; we checked their multiple domains existence etc. but didn’t find any root cause behind the same.

Then we started debugging into SharePoint logs and found the following-

"Error while executing web part: Microsoft.SharePoint.WebPartPages.WebPartPageUserException: Personalization has been disabled for this zone.     at Microsoft.SharePoint.WebPartPages.SPWebPartManager.ThrowIfCantModifyZone(String zoneID, Boolean throwIfLocked)     at Microsoft.SharePoint.WebPartPages.SPWebPartManager.ProcessZoneId(WebPart webPart, Boolean throwIfLocked)     at Microsoft.SharePoint.WebPartPages.SPWebPartManager.SaveChangesInternal(SPLayoutProperties layoutProperties, Boolean skipRightsCheck, Boolean skipSafeAgainstScriptCheck)     at Microsoft.SharePoint.WebPartPages.BaseXsltListWebPart.get_CustomizedXsl()     at Microsoft.SharePoint.WebPartPages.BaseXsltListWebPart.LoadXslCompiledTransform(WSSXmlUrlResolver someXmlResolver)     at Microsoft.SharePoint.WebPartPages.DataFormWe... 97832cag-2721-30a3-8231-7e19h27162g5

From the above error message, we have started investigating the personalization section of the webpart and finally we got it!

Here is the one Resolution:-

To resolve this issue, set the value of the AllowPersonalization attribute to "true" in all Web Parts of the Default.aspx page that has the custom portal site definitions. To do this, follow these steps:

Open the Default.aspx page of the site definition from an editing program.

1- For example, you may find the Default.aspx page in the following location:
C:\Program Files\Common Files\Microsoft Shared\web server extensions\60\TEMPLATE\1033\Custom Site Definition Folder

2- Locate the following tag in the Default.aspx file:
<WebPartPages:WebPartZone … />

3- Set the value of the AllowPersonalization attribute to "true" as in the following example:
<WebPartPages:WebPartZone AllowPersonalization="true" …/>

If you have any queries/questions regarding the above mentioned information then please let me know. I would be more than happy to help you as well as resolves your issues, Thank you.

12 December, 2013

December 2013 Cumulative Update Packages

December 2013 Cumulative Update Packages for SharePoint Foundation 2010, SharePoint Server 2010 and Project Server 2010 have been released. 

Use the following links to download the update packages:

December 2013 CU for SharePoint Foundation 2010 - KB 2849990 http://support.microsoft.com/kb/2849990

December 2013 CU for SharePoint Server 2010 - KB 2849971 http://support.microsoft.com/kb/2849971

December 2013 CU for Project Server 2010 - KB 2849972 http://support.microsoft.com/kb/2849972

Note - the March 2013 Public Update becomes the new baseline for all subsequent Updates and Service Packs.
Any known issues-Please update here!